What’s Vulnerable › Vulnerabilities
CVE-2021-23422: Arbitrary Code Injection
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-16 · updated 2026-06-17
- Weakness: CWE-78
Description
This affects the package bikeshed before 3.0.0. This can occur when an untrusted source file containing Inline Tag Command metadata is processed. When an arbitrary OS command is executed, the command output would be included in the HTML output.
Affected products
- bikeshed: before 3.0.0 — fixed in 3.0.0
How to fix
Upgrade to a fixed version: bikeshed 3.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/tabatkins/bikeshed/commit/b2f668fca204260b1cad28d5078e93471cb6b2dd
- https://snyk.io/vuln/SNYK-PYTHON-BIKESHED-1537646
- https://github.com/tabatkins/bikeshed/commit/b2f668fca204260b1cad28d5078e93471cb6b2dd
- https://snyk.io/vuln/SNYK-PYTHON-BIKESHED-1537646
Get alerted when CVE-2021-23422 or the next vulnerability affects your stack