What’s Vulnerable › Vulnerabilities
CVE-2021-23443: Cross-site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-21 · updated 2026-06-17
- Weakness: CWE-843
Description
This affects the package edge.js before 5.3.2. A type confusion vulnerability can be used to bypass input sanitization when the input to be rendered is an array (instead of a string or a SafeValue), even if {{ }} are used.
Affected products
- edge.js: before 5.3.2 — fixed in 5.3.2
How to fix
Upgrade to a fixed version: edge.js 5.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/edge-js/edge/commit/fa2c7fde86327aeae232752e89a6e37e2e469e21
- https://snyk.io/vuln/SNYK-JS-EDGEJS-1579556
- https://github.com/edge-js/edge/commit/fa2c7fde86327aeae232752e89a6e37e2e469e21
- https://snyk.io/vuln/SNYK-JS-EDGEJS-1579556
Get alerted when CVE-2021-23443 or the next vulnerability affects your stack