What’s Vulnerable › Vulnerabilities
CVE-2021-23447: Cross-site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-07 · updated 2026-06-17
- Weakness: CWE-843
Description
This affects the package teddy before 0.5.9. A type confusion vulnerability can be used to bypass input sanitization when the model content is an array (instead of a string).
Affected products
- teddy: before 0.5.9 — fixed in 0.5.9
How to fix
Upgrade to a fixed version: teddy 0.5.9. Check the vendor advisory for mitigations.
References
- https://github.com/rooseveltframework/teddy/pull/518
- https://github.com/rooseveltframework/teddy/releases/tag/0.5.9
- https://snyk.io/vuln/SNYK-JS-TEDDY-1579557
- https://github.com/rooseveltframework/teddy/pull/518
- https://github.com/rooseveltframework/teddy/releases/tag/0.5.9
- https://snyk.io/vuln/SNYK-JS-TEDDY-1579557
Get alerted when CVE-2021-23447 or the next vulnerability affects your stack