What’s Vulnerable › Vulnerabilities
CVE-2021-23470: Prototype Pollution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-04 · updated 2026-06-17
- Weakness: CWE-1321
Description
This affects the package putil-merge before 3.8.0. The merge() function does not check the values passed into the argument. An attacker can supply a malicious value by adjusting the value to include the constructor property. Note: This vulnerability derives from an incomplete fix in https://security.snyk.io/vuln/SNYK-JS-PUTILMERGE-1317077
Affected products
- putil-merge: before 3.8.0 — fixed in 3.8.0
How to fix
Upgrade to a fixed version: putil-merge 3.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/panates/putil-merge/commit/476d00078dfb2827d7c9ee0f2392c81b864f7bc5
- https://snyk.io/vuln/SNYK-JS-PUTILMERGE-2391487
- https://github.com/panates/putil-merge/commit/476d00078dfb2827d7c9ee0f2392c81b864f7bc5
- https://snyk.io/vuln/SNYK-JS-PUTILMERGE-2391487
Get alerted when CVE-2021-23470 or the next vulnerability affects your stack