What’s Vulnerable › Vulnerabilities
CVE-2021-23514: Path Traversal
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-13 · updated 2026-06-17
- Weakness: CWE-22
Description
This affects the package Crow before 0.3+4. It is possible to traverse directories to fetch arbitrary files from the server.
Affected products
- Crow: before 0.3\+4 — fixed in 0.3\+4
How to fix
Upgrade to a fixed version: Crow 0.3\+4. Check the vendor advisory for mitigations.
References
- https://github.com/CrowCpp/Crow/pull/317
- https://github.com/CrowCpp/Crow/releases/tag/v0.3%2B4
- https://snyk.io/vuln/SNYK-UNMANAGED-CROW-2336163
- https://github.com/CrowCpp/Crow/pull/317
- https://github.com/CrowCpp/Crow/releases/tag/v0.3%2B4
- https://snyk.io/vuln/SNYK-UNMANAGED-CROW-2336163
Get alerted when CVE-2021-23514 or the next vulnerability affects your stack