What’s Vulnerable › Vulnerabilities
CVE-2021-23556: Exposed Dangerous Method or Function
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-17 · updated 2026-06-17
Description
The package guake before 3.8.5 are vulnerable to Exposed Dangerous Method or Function due to the exposure of execute_command and execute_command_by_uuid methods via the d-bus interface, which makes it possible for a malicious user to run an arbitrary command via the d-bus method. **Note:** Exploitation requires the user to have installed another malicious program that will be able to send dbus signals or run terminal commands.
Affected products
- guake: before 3.8.5 — fixed in 3.8.5
How to fix
Upgrade to a fixed version: guake 3.8.5. Check the vendor advisory for mitigations.
References
- https://github.com/Guake/guake/issues/1796
- https://github.com/Guake/guake/pull/2017
- https://github.com/Guake/guake/pull/2017/commits/e3d671120bfe7ba28f50e256cc5e8a629781b888
- https://github.com/Guake/guake/releases
- https://snyk.io/vuln/SNYK-PYTHON-GUAKE-2386334
- https://github.com/Guake/guake/issues/1796
- https://github.com/Guake/guake/pull/2017
- https://github.com/Guake/guake/pull/2017/commits/e3d671120bfe7ba28f50e256cc5e8a629781b888
- https://github.com/Guake/guake/releases
- https://snyk.io/vuln/SNYK-PYTHON-GUAKE-2386334
Get alerted when CVE-2021-23556 or the next vulnerability affects your stack