What’s Vulnerable › Vulnerabilities
CVE-2021-23718: Server-side Request Forgery (SSRF)
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-22 · updated 2026-06-17
- Weakness: CWE-918
Description
The package ssrf-agent before 1.0.5 are vulnerable to Server-side Request Forgery (SSRF) via the defaultIpChecker function. It fails to properly validate if the IP requested is private.
Affected products
- ssrf-agent: before 1.0.5 — fixed in 1.0.5
How to fix
Upgrade to a fixed version: ssrf-agent 1.0.5. Check the vendor advisory for mitigations.
References
- https://github.com/welefen/ssrf-agent/blob/cec2b85fe8886ad6926a247a3e059d8369ec022b/index.js%23L13
- https://security.netapp.com/advisory/ntap-20211203-0005/
- https://snyk.io/vuln/SNYK-JS-SSRFAGENT-1584362
- https://github.com/welefen/ssrf-agent/blob/cec2b85fe8886ad6926a247a3e059d8369ec022b/index.js%23L13
- https://security.netapp.com/advisory/ntap-20211203-0005/
- https://snyk.io/vuln/SNYK-JS-SSRFAGENT-1584362
Get alerted when CVE-2021-23718 or the next vulnerability affects your stack