What’s Vulnerable › Vulnerabilities
CVE-2021-23727: Stored Command Injection
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-29 · updated 2026-06-17
- Weakness: CWE-77
Description
This affects the package celery before 5.2.2. It by default trusts the messages and metadata stored in backends (result stores). When reading task metadata from the backend, the data is deserialized. Given that an attacker can gain access to, or somehow manipulate the metadata within a celery backend, they could trigger a stored command injection vulnerability and potentially gain further access to the system.
Affected products
- Celeryproject Celery: before 5.2.2 — fixed in 5.2.2
- Fedoraproject Extra Packages For Enterprise Linux: 7.0
- Fedoraproject Fedora: 35
How to fix
Upgrade to a fixed version: Celeryproject Celery 5.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/celery/celery/blob/master/Changelog.rst%23522
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SYXRGHWHD2WWMHBWCVD5ULVINPKNY3P5/
- https://snyk.io/vuln/SNYK-PYTHON-CELERY-2314953
- https://github.com/celery/celery/blob/master/Changelog.rst%23522
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SYXRGHWHD2WWMHBWCVD5ULVINPKNY3P5/
- https://snyk.io/vuln/SNYK-PYTHON-CELERY-2314953
Get alerted when CVE-2021-23727 or the next vulnerability affects your stack