What’s Vulnerable › Vulnerabilities
CVE-2021-23824: Content Injection
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-13 · updated 2026-06-17
- Weakness: CWE-79
Description
This affects the package Crow before 0.3+4. When using attributes without quotes in the template, an attacker can manipulate the input to introduce additional attributes, potentially executing code. This may lead to a Cross-site Scripting (XSS) vulnerability, assuming an attacker can influence the value entered into the template. If the template is used to render user-generated content, this vulnerability may escalate to a persistent XSS vulnerability.
Affected products
- Crow: before 0.3\+4 — fixed in 0.3\+4
How to fix
Upgrade to a fixed version: Crow 0.3\+4. Check the vendor advisory for mitigations.
References
- https://github.com/CrowCpp/Crow/pull/317
- https://github.com/CrowCpp/Crow/releases/tag/v0.3%2B4
- https://snyk.io/vuln/SNYK-UNMANAGED-CROW-2336164
- https://github.com/CrowCpp/Crow/pull/317
- https://github.com/CrowCpp/Crow/releases/tag/v0.3%2B4
- https://snyk.io/vuln/SNYK-UNMANAGED-CROW-2336164
Get alerted when CVE-2021-23824 or the next vulnerability affects your stack