What’s Vulnerable › Vulnerabilities
CVE-2021-23840: Integer overflow in CipherUpdate
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 50.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-02-16 · updated 2026-06-17
- Weakness: CWE-190
Description
Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform. In such cases the return value from the function call will be 1 (indicating success), but the output length value will be negative. This could cause applications to behave incorrectly or crash. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).
Affected products
- Debian Linux: 10.0
- Fujitsu M10-1 Firmware: before xcp2410; before xcp3110 — fixed in xcp2410, xcp3110
- Fujitsu M10-4 Firmware: before xcp2410; before xcp3110 — fixed in xcp2410, xcp3110
- Fujitsu M10-4S Firmware: before xcp2410; before xcp3110 — fixed in xcp2410, xcp3110
- Fujitsu M12-1 Firmware: before xcp2410; before xcp3110 — fixed in xcp2410, xcp3110
- Fujitsu M12-2 Firmware: before xcp2410; before xcp3110 — fixed in xcp2410, xcp3110
- Fujitsu M12-2S Firmware: before xcp2410; before xcp3110 — fixed in xcp2410, xcp3110
- McAfee,LLC McAfee ePolicy Orchestrator (ePO): before 5.10.0; 5.10.0, 5.10.0-update_1, 5.10.0-update_10, 5.10.0-update_2, 5.10.0-update_3, 5.10.0-update_4 (+5) — fixed in 5.10.0
- Node.js: from 10.0.0 through 10.12.0; from 10.13.0 before 10.24.0; from 12.0.0 through 12.12.0; from 12.13.0 before 12.21.0; from 14.0.0 through 14.14.0; from 15.0.0 before 15.10.0 — fixed in 10.24.0, 12.21.0, 15.10.0
- OpenSSL: from 1.0.2 before 1.0.2y; from 1.1.1 before 1.1.1j — fixed in 1.0.2y, 1.1.1j
- Oracle Corporation Oracle Business Intelligence Enterprise Edition: 5.5.0.0.0, 5.9.0.0.0, 12.2.1.3.0, 12.2.1.4.0
- Oracle Communications Cloud Native Core Policy: 1.15.0
- Oracle Enterprise Manager For Storage Management: 13.4.0.0
- Oracle Corporation Enterprise Manager Ops Center: 12.4.0.0
- Oracle Corporation GraalVM Enterprise Edition: 19.3.5, 20.3.1.2, 21.0.0.2
- Oracle Corporation JD Edwards EnterpriseOne Tools: before 9.2.6.0 — fixed in 9.2.6.0
- Oracle Jd Edwards World Security: a9.4
- MySQL Server: before 5.7.33; from 8.0.15 before 8.0.23 — fixed in 5.7.33, 8.0.23
- Oracle Nosql Database: before 20.3 — fixed in 20.3
- Tenable Log Correlation Engine: before 6.0.8 — fixed in 6.0.8
- Tenable Nessus Network Monitor: 5.11.0, 5.11.1, 5.12.0, 5.12.1, 5.13.0
How to fix
Upgrade to a fixed version: Fujitsu M10-1 Firmware xcp2410, xcp3110; Fujitsu M10-4 Firmware xcp2410, xcp3110; Fujitsu M10-4S Firmware xcp2410, xcp3110; Fujitsu M12-1 Firmware xcp2410, xcp3110; Fujitsu M12-2 Firmware xcp2410, xcp3110; Fujitsu M12-2S Firmware xcp2410, xcp3110; McAfee,LLC McAfee ePolicy Orchestrator (ePO) 5.10.0; Node.js 10.24.0, 12.21.0, 15.10.0; OpenSSL 1.0.2y, 1.1.1j; Oracle Corporation JD Edwards EnterpriseOne Tools 9.2.6.0; MySQL Server 5.7.33, 8.0.23; Oracle Nosql Database 20.3. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-389290.pdf
- https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=6a51b9e1d0cf0bf8515f7201b68fb0a3482b3dc1
- https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=9b1129239f3ebb1d1c98ce9ed41d5c9476c47cb2
- https://kb.pulsesecure.net/articles/Pulse_Security_Advisories/SA44846
- https://kc.mcafee.com/corporate/index?page=content&id=SB10366
- https://lists.apache.org/thread.html/r58af02e294bd07f487e2c64ffc0a29b837db5600e33b6e698b9d696b%40%3Cissues.bookkeeper.apache.org%3E
- https://lists.apache.org/thread.html/rf4c02775860db415b4955778a131c2795223f61cb8c6a450893651e4%40%3Cissues.bookkeeper.apache.org%3E
- https://security.gentoo.org/glsa/202103-03
- https://security.netapp.com/advisory/ntap-20210219-0009/
- https://security.netapp.com/advisory/ntap-20240621-0006/
- https://www.debian.org/security/2021/dsa-4855
- https://www.openssl.org/news/secadv/20210216.txt
Get alerted when CVE-2021-23840 or the next vulnerability affects your stack