What’s Vulnerable › Vulnerabilities
CVE-2021-23889: McAfee ePO Cross-site Scripting vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-26 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-Site Scripting vulnerability in McAfee ePolicy Orchestrator (ePO) prior to 5.10 Update 10 allows ePO administrators to inject arbitrary web script or HTML via multiple parameters where the administrator's entries were not correctly sanitized.
Affected products
- McAfee,LLC McAfee ePolicy Orchestrator (ePO): before 5.10.0; 5.10.0, 5.10.0-update_1, 5.10.0-update_2, 5.10.0-update_3, 5.10.0-update_4, 5.10.0-update_5 (+4) — fixed in 5.10.0
How to fix
Upgrade to a fixed version: McAfee,LLC McAfee ePolicy Orchestrator (ePO) 5.10.0. Check the vendor advisory for mitigations.
References
- https://kc.mcafee.com/corporate/index?page=content&id=SB10352
- https://kc.mcafee.com/corporate/index?page=content&id=SB10352
Get alerted when CVE-2021-23889 or the next vulnerability affects your stack