What’s Vulnerable › Vulnerabilities
CVE-2021-23974
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-02-26 · updated 2026-06-17
Description
The DOMParser API did not properly process '<noscript>' elements for escaping. This could be used as an mXSS vector to bypass an HTML Sanitizer. This vulnerability affects Firefox < 86.
Affected products
- Mozilla Firefox: before 86.0 — fixed in 86.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 86.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/buglist.cgi?bug_id=1528997%2C1683627
- https://security.gentoo.org/glsa/202104-10
- https://www.mozilla.org/security/advisories/mfsa2021-07/
- https://bugzilla.mozilla.org/buglist.cgi?bug_id=1528997%2C1683627
- https://security.gentoo.org/glsa/202104-10
- https://www.mozilla.org/security/advisories/mfsa2021-07/
Get alerted when CVE-2021-23974 or the next vulnerability affects your stack