What’s Vulnerable › Vulnerabilities
CVE-2021-24005
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-06 · updated 2026-06-17
- Weakness: CWE-798
Description
Usage of hard-coded cryptographic keys to encrypt configuration files and debug logs in FortiAuthenticator versions before 6.3.0 may allow an attacker with access to the files or the CLI configuration to decrypt the sensitive data, via knowledge of the hard-coded key.
Affected products
- Fortinet FortiAuthenticator: from 6.0.0 before 6.3.0 — fixed in 6.3.0
How to fix
Upgrade to a fixed version: Fortinet FortiAuthenticator 6.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-24005 or the next vulnerability affects your stack