What’s Vulnerable › Vulnerabilities
CVE-2021-24007
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-09 · updated 2026-06-17
- Weakness: CWE-89
Description
Multiple improper neutralization of special elements of SQL commands vulnerabilities in FortiMail before 6.4.4 may allow a non-authenticated attacker to execute unauthorized code or commands via specifically crafted HTTP requests.
Affected products
- Fortinet FortiMail: through 5.4.12; from 5.6.1 before 6.0.11; from 6.2.0 before 6.2.7; from 6.4.0 before 6.4.4 — fixed in 6.0.11, 6.2.7, 6.4.4
How to fix
Upgrade to a fixed version: Fortinet FortiMail 6.0.11, 6.2.7, 6.4.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-24007 or the next vulnerability affects your stack