What’s Vulnerable › Vulnerabilities
CVE-2021-24015
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-12 · updated 2026-06-17
- Weakness: CWE-78
Description
An improper neutralization of special elements used in an OS Command vulnerability in the administrative interface of FortiMail before 6.4.4 may allow an authenticated attacker to execute unauthorized commands via specifically crafted HTTP requests.
Affected products
- Fortinet FortiMail: from 5.4.0 through 5.4.12; from 6.0.0 before 6.0.11; from 6.2.0 before 6.2.7; from 6.4.0 before 6.4.4 — fixed in 6.0.11, 6.2.7, 6.4.4
How to fix
Upgrade to a fixed version: Fortinet FortiMail 6.0.11, 6.2.7, 6.4.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-24015 or the next vulnerability affects your stack