What’s Vulnerable › Vulnerabilities
CVE-2021-24018
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-04 · updated 2026-06-17
- Weakness: CWE-787
Description
A buffer underwrite vulnerability in the firmware verification routine of FortiOS before 7.0.1 may allow an attacker located in the adjacent network to potentially execute arbitrary code via a specifically crafted firmware image.
Affected products
- Fortinet FortiOS (FortiGate): before 6.2.10; from 6.4.0 before 6.4.7; 7.0.0 — fixed in 6.2.10, 6.4.7
How to fix
Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 6.2.10, 6.4.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-24018 or the next vulnerability affects your stack