What’s Vulnerable › Vulnerabilities
CVE-2021-24025
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-10 · updated 2026-06-17
- Weakness: CWE-122
Description
Due to incorrect string size calculations inside the preg_quote function, a large input string passed to the function can trigger an integer overflow leading to a heap overflow. This issue affects HHVM versions prior to 4.56.3, all versions between 4.57.0 and 4.80.1, all versions between 4.81.0 and 4.93.1, and versions 4.94.0, 4.95.0, 4.96.0, 4.97.0, 4.98.0.
Affected products
- Facebook HHVM: before 4.56.3; from 4.57.0 through 4.80.1; from 4.81.0 through 4.93.1; 4.94.0, 4.95.0, 4.96.0, 4.97.0, 4.98.0 — fixed in 4.56.3
How to fix
Upgrade to a fixed version: Facebook HHVM 4.56.3. Check the vendor advisory for mitigations.
References
- https://github.com/facebook/hhvm/commit/08193b7f0cd3910256e00d599f0f3eb2519c44ca
- https://hhvm.com/blog/2021/02/25/security-update.html
- https://github.com/facebook/hhvm/commit/08193b7f0cd3910256e00d599f0f3eb2519c44ca
- https://hhvm.com/blog/2021/02/25/security-update.html
Get alerted when CVE-2021-24025 or the next vulnerability affects your stack