What’s Vulnerable › Vulnerabilities
CVE-2021-24036
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-23 · updated 2026-06-17
- Weakness: CWE-122
Description
Passing an attacker controlled size when creating an IOBuf could cause integer overflow, leading to an out of bounds write on the heap with the possibility of remote code execution. This issue affects versions of folly prior to v2021.07.22.00. This issue affects HHVM versions prior to 4.80.5, all versions between 4.81.0 and 4.102.1, all versions between 4.103.0 and 4.113.0, and versions 4.114.0, 4.115.0, 4.116.0, 4.117.0, 4.118.0 and 4.118.1.
Affected products
- Facebook folly: before 2021.07.22.00 — fixed in 2021.07.22.00
- Facebook HHVM: before 4.80.5; from 4.81.0 through 4.102.1; from 4.103.0 through 4.113.0; 4.114.0, 4.115.0, 4.116.0, 4.117.0, 4.118.0, 4.118.1 — fixed in 4.80.5
How to fix
Upgrade to a fixed version: Facebook folly 2021.07.22.00; Facebook HHVM 4.80.5. Check the vendor advisory for mitigations.
References
- https://github.com/facebook/folly/commit/4f304af1411e68851bdd00ef6140e9de4616f7d3
- https://hhvm.com/blog/2021/07/20/security-update.html
- https://www.facebook.com/security/advisories/cve-2021-24036
- https://github.com/facebook/folly/commit/4f304af1411e68851bdd00ef6140e9de4616f7d3
- https://hhvm.com/blog/2021/07/20/security-update.html
- https://www.facebook.com/security/advisories/cve-2021-24036
Get alerted when CVE-2021-24036 or the next vulnerability affects your stack