What’s Vulnerable › Vulnerabilities
CVE-2021-24040
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 17.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-10 · updated 2026-06-17
- Weakness: CWE-502
Description
Due to use of unsafe YAML deserialization logic, an attacker with the ability to modify local YAML configuration files could provide malicious input, resulting in remote code execution or similar risks. This issue affects ParlAI prior to v1.1.0.
Affected products
- Facebook ParlAI: before 1.1.0 — fixed in 1.1.0
How to fix
Upgrade to a fixed version: Facebook ParlAI 1.1.0. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/164136/Facebook-ParlAI-1.0.0-Code-Execution-Deserialization.html
- https://github.com/facebookresearch/ParlAI/releases/tag/v1.1.0
- https://github.com/facebookresearch/ParlAI/security/advisories/GHSA-m87f-9fvv-2mgg
- http://packetstormsecurity.com/files/164136/Facebook-ParlAI-1.0.0-Code-Execution-Deserialization.html
- https://github.com/facebookresearch/ParlAI/releases/tag/v1.1.0
- https://github.com/facebookresearch/ParlAI/security/advisories/GHSA-m87f-9fvv-2mgg
Get alerted when CVE-2021-24040 or the next vulnerability affects your stack