What’s Vulnerable › Vulnerabilities
CVE-2021-24044
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-15 · updated 2026-06-17
- Weakness: CWE-843
Description
By passing invalid javascript code where await and yield were called upon non-async and non-generator getter/setter functions, Hermes would invoke generator functions and error out on invalid await/yield positions. This could result in segmentation fault as a consequence of type confusion error, with a low chance of RCE. This issue affects Hermes versions prior to v0.10.0.
Affected products
- Facebook Hermes: before 0.10.0 — fixed in 0.10.0
How to fix
Upgrade to a fixed version: Facebook Hermes 0.10.0. Check the vendor advisory for mitigations.
References
- https://www.facebook.com/security/advisories/cve-2021-24044
- https://www.facebook.com/security/advisories/cve-2021-24044
Get alerted when CVE-2021-24044 or the next vulnerability affects your stack