What’s Vulnerable › Vulnerabilities
CVE-2021-24127: ThirstyAffiliates < 3.9.3 - Authenticated Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Unvalidated input and lack of output encoding in the ThirstyAffiliates Affiliate Link Manager WordPress plugin, versions before 3.9.3, was vulnerable to authenticated Stored Cross-Site Scripting (XSS), which could lead to privilege escalation.
Affected products
- ThirstyAffiliates: before 3.9.3 — fixed in 3.9.3
How to fix
Upgrade to a fixed version: ThirstyAffiliates 3.9.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/1fbd9f7a-6f99-45a2-9d57-01631a1f35d6
- https://wpscan.com/vulnerability/1fbd9f7a-6f99-45a2-9d57-01631a1f35d6
Get alerted when CVE-2021-24127 or the next vulnerability affects your stack