What’s Vulnerable › Vulnerabilities
CVE-2021-24129: Themify Portfolio Post < 1.1.6 - Authenticated Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Unvalidated input and lack of output encoding in the Themify Portfolio Post WordPress plugin, versions before 1.1.6, lead to Stored Cross-Site Scripting (XSS) vulnerabilities allowing low-privileged users (Contributor+) to inject arbitrary JavaScript code or HTML in posts where the Themify Custom Panel is embedded, which could lead to privilege escalation.
Affected products
- Themify Portfolio Post: before 1.1.6 — fixed in 1.1.6
How to fix
Upgrade to a fixed version: Themify Portfolio Post 1.1.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c8537e5f-1948-418b-9d29-3cf50cd8f9a6
- https://wpscan.com/vulnerability/c8537e5f-1948-418b-9d29-3cf50cd8f9a6
Get alerted when CVE-2021-24129 or the next vulnerability affects your stack