What’s Vulnerable › Vulnerabilities
CVE-2021-24130: WP Google Map Plugin < 4.1.5 - Authenticated SQL Injection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-18 · updated 2026-06-17
- Weakness: CWE-89
Description
Unvalidated input in the WP Google Map Plugin WordPress plugin, versions before 4.1.5, in the Manage Locations page within the plugin settings was vulnerable to SQL Injection through a high privileged user (admin+).
Affected products
- WP Maps: before 4.1.5 — fixed in 4.1.5
How to fix
Upgrade to a fixed version: WP Maps 4.1.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/46af9a4d-67ac-4e08-a753-a2a44245f4f8
- https://wpscan.com/vulnerability/46af9a4d-67ac-4e08-a753-a2a44245f4f8
Get alerted when CVE-2021-24130 or the next vulnerability affects your stack