What’s Vulnerable › Vulnerabilities
CVE-2021-24134: Constant Contact Forms < 1.8.8 - Multiple Authenticated Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Unvalidated input and lack of output encoding in the Constant Contact Forms WordPress plugin, versions before 1.8.8, lead to multiple Stored Cross-Site Scripting vulnerabilities, which allowed high-privileged user (Editor+) to inject arbitrary JavaScript code or HTML in posts where the malicious form is embed.
Affected products
- Constant Contact Forms: before 1.8.8 — fixed in 1.8.8
How to fix
Upgrade to a fixed version: Constant Contact Forms 1.8.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/8f3cca92-d072-4806-9142-7f1a987f840b
- https://wpscan.com/vulnerability/8f3cca92-d072-4806-9142-7f1a987f840b
Get alerted when CVE-2021-24134 or the next vulnerability affects your stack