What’s Vulnerable › Vulnerabilities
CVE-2021-24138: AdRotate < 5.8.4 - Authenticated SQL Injection
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-18 · updated 2026-06-17
- Weakness: CWE-89
Description
Unvalidated input in the AdRotate WordPress plugin, versions before 5.8.4, leads to Authenticated SQL injection via param "id". This requires an admin privileged user.
Affected products
- AdRotate – Ad manager & AdSense Ads: before 5.8.4 — fixed in 5.8.4
How to fix
Upgrade to a fixed version: AdRotate – Ad manager & AdSense Ads 5.8.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/aafac655-3616-4b27-9d0f-1cbc2faf0151
- https://wpscan.com/vulnerability/aafac655-3616-4b27-9d0f-1cbc2faf0151
Get alerted when CVE-2021-24138 or the next vulnerability affects your stack