What’s Vulnerable › Vulnerabilities
CVE-2021-24140: Ajax Load More < 5.3.2 - Authenticated SQL Injection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-18 · updated 2026-06-17
- Weakness: CWE-89
Description
Unvalidated input in the Ajax Load More WordPress plugin, versions before 5.3.2, lead to SQL Injection in POST /wp-admin/admin-ajax.php with param repeater=' or sleep(5)#&type=test.
Affected products
- dcooney Ajax Load More – Infinite Scroll, Load More, & Lazy Load: before 5.3.2 — fixed in 5.3.2
How to fix
Upgrade to a fixed version: dcooney Ajax Load More – Infinite Scroll, Load More, & Lazy Load 5.3.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/1876312e-3dba-4909-97a5-afbb76fbc056
- https://wpscan.com/vulnerability/1876312e-3dba-4909-97a5-afbb76fbc056
Get alerted when CVE-2021-24140 or the next vulnerability affects your stack