What’s Vulnerable › Vulnerabilities
CVE-2021-24147: Modern Events Calendar Lite < 5.16.5 - Authenticated Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Unvalidated input and lack of output encoding in the Modern Events Calendar Lite WordPress plugin, versions before 5.16.5, did not sanitise the mic_comment field (Notes on time) when adding/editing an event, allowing users with privilege as low as author to add events with a Cross-Site Scripting payload in them, which will be triggered in the frontend when viewing the event.
Affected products
- Modern Events Calendar Lite: before 5.16.5 — fixed in 5.16.5
How to fix
Upgrade to a fixed version: Modern Events Calendar Lite 5.16.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0f9ba284-5d7e-4092-8344-c68316b0146f
- https://wpscan.com/vulnerability/0f9ba284-5d7e-4092-8344-c68316b0146f
Get alerted when CVE-2021-24147 or the next vulnerability affects your stack