What’s Vulnerable › Vulnerabilities
CVE-2021-24153: Yoast SEO < 3.4.1 - Authenticated Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-05 · updated 2026-06-17
- Weakness: CWE-79
Description
A Stored Cross-Site Scripting vulnerability was discovered in the Yoast SEO WordPress plugin before 3.4.1, which had built-in blacklist filters which were blacklisting Parenthesis as well as several functions such as alert but bypasses were found.
Affected products
- Yoast SEO: Local: before 3.4.1 — fixed in 3.4.1
How to fix
Upgrade to a fixed version: Yoast SEO: Local 3.4.1. Check the vendor advisory for mitigations.
References
- https://packetstormsecurity.com/files/138192/
- https://plugins.trac.wordpress.org/changeset/1466243/wordpress-seo
- https://wpscan.com/vulnerability/77810044-394d-4314-b9a1-20c7dca726dc
- https://packetstormsecurity.com/files/138192/
- https://plugins.trac.wordpress.org/changeset/1466243/wordpress-seo
- https://wpscan.com/vulnerability/77810044-394d-4314-b9a1-20c7dca726dc
Get alerted when CVE-2021-24153 or the next vulnerability affects your stack