What’s Vulnerable › Vulnerabilities
CVE-2021-24155: Backup Guard < 1.6.0 - Authenticated Arbitrary File Upload
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 84.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-05 · updated 2026-06-17
- Weakness: CWE-434
Description
The WordPress Backup and Migrate Plugin – Backup Guard WordPress plugin before 1.6.0 did not ensure that the imported files are of the SGBP format and extension, allowing high privilege users (admin+) to upload arbitrary files, including PHP ones, leading to RCE.
Affected products
- BackupGuard: before 1.6.0 — fixed in 1.6.0
How to fix
Upgrade to a fixed version: BackupGuard 1.6.0. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/163382/WordPress-Backup-Guard-1.5.8-Shell-Upload.html
- http://packetstormsecurity.com/files/163623/WordPress-Backup-Guard-Authenticated-Remote-Code-Execution.html
- https://wpscan.com/vulnerability/d442acac-4394-45e4-b6bb-adf4a40960fb
- http://packetstormsecurity.com/files/163382/WordPress-Backup-Guard-1.5.8-Shell-Upload.html
- http://packetstormsecurity.com/files/163623/WordPress-Backup-Guard-Authenticated-Remote-Code-Execution.html
- https://wpscan.com/vulnerability/d442acac-4394-45e4-b6bb-adf4a40960fb
Get alerted when CVE-2021-24155 or the next vulnerability affects your stack