What’s Vulnerable › Vulnerabilities
CVE-2021-24168: Easy Contact Form Pro < 1.1.1.9 - Authenticated Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The Easy Contact Form Pro WordPress plugin before 1.1.1.9 did not properly sanitise the text fields (such as Email Subject, Email Recipient, etc) when creating or editing a form, leading to an authenticated (author+) stored cross-site scripting issue. This could allow medium privilege accounts (such as author and editor) to perform XSS attacks against high privilege ones like administrator.
Affected products
- Easy Contact Form Pro: before 1.1.1.9 — fixed in 1.1.1.9
How to fix
Upgrade to a fixed version: Easy Contact Form Pro 1.1.1.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/bfaa7d79-904e-45f1-bc42-ddd90a65ce74
- https://wpscan.com/vulnerability/bfaa7d79-904e-45f1-bc42-ddd90a65ce74
Get alerted when CVE-2021-24168 or the next vulnerability affects your stack