What’s Vulnerable › Vulnerabilities
CVE-2021-24178: Business Directory Plugin < 5.11.1 - Arbitrary Add/Edit/Delete Form Field to Stored XSS
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-06 · updated 2026-06-17
- Weakness: CWE-352
Description
The Business Directory Plugin – Easy Listing Directories for WordPress WordPress plugin before 5.11.1 suffered from Cross-Site Request Forgery issues, allowing an attacker to make a logged in administrator add, edit or delete form fields, which could also lead to Stored Cross-Site Scripting issues.
Affected products
- Business Directory Team Business Directory Plugin – Easy Listing Directories for WordPress: before 5.11.1 — fixed in 5.11.1
How to fix
Upgrade to a fixed version: Business Directory Team Business Directory Plugin – Easy Listing Directories for WordPress 5.11.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/700f3b04-8298-447c-8d3c-4581880a63b5
- https://wpscan.com/vulnerability/700f3b04-8298-447c-8d3c-4581880a63b5
Get alerted when CVE-2021-24178 or the next vulnerability affects your stack