What’s Vulnerable › Vulnerabilities
CVE-2021-24181: Tutor LMS < 1.7.7 - SQL Injection via tutor_mark_answer_as_correct
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-05 · updated 2026-06-17
- Weakness: CWE-89
Description
The tutor_mark_answer_as_correct AJAX action from the Tutor LMS – eLearning and online course solution WordPress plugin before 1.7.7 was vulnerable to blind and time based SQL injections that could be exploited by students.
Affected products
- themeum Tutor LMS – eLearning and online course solution: before 1.7.7 — fixed in 1.7.7
How to fix
Upgrade to a fixed version: themeum Tutor LMS – eLearning and online course solution 1.7.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d5a00322-7098-4f8d-8e5e-157b63449c17
- https://www.wordfence.com/blog/2021/03/several-vulnerabilities-patched-in-tutor-lms-plugin/
- https://wpscan.com/vulnerability/d5a00322-7098-4f8d-8e5e-157b63449c17
- https://www.wordfence.com/blog/2021/03/several-vulnerabilities-patched-in-tutor-lms-plugin/
Get alerted when CVE-2021-24181 or the next vulnerability affects your stack