What’s Vulnerable › Vulnerabilities
CVE-2021-24184: Tutor LMS < 1.7.7 - Unprotected AJAX including Privilege Escalation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-05 · updated 2026-06-17
- Weakness: CWE-862
Description
Several AJAX endpoints in the Tutor LMS – eLearning and online course solution WordPress plugin before 1.7.7 were unprotected, allowing students to modify course information and elevate their privileges among many other actions.
Affected products
- themeum Tutor LMS – eLearning and online course solution: before 1.7.7 — fixed in 1.7.7
How to fix
Upgrade to a fixed version: themeum Tutor LMS – eLearning and online course solution 1.7.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5e85917c-7a58-49cb-b8b3-05aa18ffff3e
- https://www.wordfence.com/blog/2021/03/several-vulnerabilities-patched-in-tutor-lms-plugin/
- https://wpscan.com/vulnerability/5e85917c-7a58-49cb-b8b3-05aa18ffff3e
- https://www.wordfence.com/blog/2021/03/several-vulnerabilities-patched-in-tutor-lms-plugin/
Get alerted when CVE-2021-24184 or the next vulnerability affects your stack