What’s Vulnerable › Vulnerabilities
CVE-2021-24186: Tutor LMS < 1.8.3 - SQL Injection via tutor_answering_quiz_question/get_answer_by_id
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-05 · updated 2026-06-17
- Weakness: CWE-89
Description
The tutor_answering_quiz_question/get_answer_by_id function pair from the Tutor LMS – eLearning and online course solution WordPress plugin before 1.8.3 was vulnerable to UNION based SQL injection that could be exploited by students.
Affected products
- themeum Tutor LMS – eLearning and online course solution: before 1.8.3 — fixed in 1.8.3
How to fix
Upgrade to a fixed version: themeum Tutor LMS – eLearning and online course solution 1.8.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5f5c0c6c-6f76-4366-b590-0aab557f8c60
- https://www.wordfence.com/blog/2021/03/several-vulnerabilities-patched-in-tutor-lms-plugin/
- https://wpscan.com/vulnerability/5f5c0c6c-6f76-4366-b590-0aab557f8c60
- https://www.wordfence.com/blog/2021/03/several-vulnerabilities-patched-in-tutor-lms-plugin/
Get alerted when CVE-2021-24186 or the next vulnerability affects your stack