What’s Vulnerable › Vulnerabilities
CVE-2021-24188: WP Content Copy Protection & No Right Click < 3.1.5 - Arbitrary Plugin Installation/Activation via Low Privilege User
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-14 · updated 2026-06-17
- Weakness: CWE-285
Description
Low privileged users can use the AJAX action 'cp_plugins_do_button_job_later_callback' in the WP Content Copy Protection & No Right Click WordPress plugin before 3.1.5, to install any plugin (including a specific version) from the WordPress repository, as well as activate arbitrary plugin from then blog, which helps attackers install vulnerable plugins and could lead to more critical vulnerabilities like RCE.
Affected products
- wp-buy WP Content Copy Protection & No Right Click: before 3.1.5 — fixed in 3.1.5
How to fix
Upgrade to a fixed version: wp-buy WP Content Copy Protection & No Right Click 3.1.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/74889e29-5349-43d1-baf5-1622493be90c
- https://wpscan.com/vulnerability/74889e29-5349-43d1-baf5-1622493be90c
Get alerted when CVE-2021-24188 or the next vulnerability affects your stack