What’s Vulnerable › Vulnerabilities
CVE-2021-24191: WP Maintenance Mode & Site Under Construction < 1.8.2 - Arbitrary Plugin Installation/Activation via Low Privilege User
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-14 · updated 2026-06-17
- Weakness: CWE-285
Description
Low privileged users can use the AJAX action 'cp_plugins_do_button_job_later_callback' in the WP Maintenance Mode & Site Under Construction WordPress plugin before 1.8.2, to install any plugin (including a specific version) from the WordPress repository, as well as activate arbitrary plugin from then blog, which helps attackers install vulnerable plugins and could lead to more critical vulnerabilities like RCE.
Affected products
- wpshopmart Coming Soon Page & Maintenance Mode: before 1.8.2 — fixed in 1.8.2
How to fix
Upgrade to a fixed version: wpshopmart Coming Soon Page & Maintenance Mode 1.8.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/74889e29-5349-43d1-baf5-1622493be90c
- https://wpscan.com/vulnerability/74889e29-5349-43d1-baf5-1622493be90c
Get alerted when CVE-2021-24191 or the next vulnerability affects your stack