What’s Vulnerable › Vulnerabilities
CVE-2021-24203: Elementor < 3.1.2 - Authenticated Stored Cross-Site Scripting (XSS) in Divider Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-05 · updated 2026-06-17
- Weakness: CWE-79
Description
In the Elementor Website Builder WordPress plugin before 3.1.4, the divider widget (includes/widgets/divider.php) accepts an ‘html_tag’ parameter. Although the element control lists a fixed set of possible html tags, it is possible for a user with Contributor or above permissions to send a modified ‘save_builder’ request with this parameter set to ‘script’ and combined with a ‘text’ parameter containing JavaScript, which will then be executed when the saved page is viewed or previewed.
Affected products
- Elementor Website Builder: before 3.1.4 — fixed in 3.1.4
How to fix
Upgrade to a fixed version: Elementor Website Builder 3.1.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/aa152ad0-5b3d-4d1f-88f4-6899a546e72e
- https://www.wordfence.com/blog/2021/03/cross-site-scripting-vulnerabilities-in-elementor-impact-over-7-million-sites/
- https://wpscan.com/vulnerability/aa152ad0-5b3d-4d1f-88f4-6899a546e72e
- https://www.wordfence.com/blog/2021/03/cross-site-scripting-vulnerabilities-in-elementor-impact-over-7-million-sites/
Get alerted when CVE-2021-24203 or the next vulnerability affects your stack