What’s Vulnerable › Vulnerabilities
CVE-2021-24204: Elementor < 3.1.2 - Authenticated Stored Cross-Site Scripting (XSS) in Accordion Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-05 · updated 2026-06-17
- Weakness: CWE-79
Description
In the Elementor Website Builder WordPress plugin before 3.1.4, the accordion widget (includes/widgets/accordion.php) accepts a ‘title_html_tag’ parameter. Although the element control lists a fixed set of possible html tags, it is possible for a user with Contributor or above permissions to send a modified ‘save_builder’ request containing JavaScript in the ‘title_html_tag’ parameter, which is not filtered and is output without escaping. This JavaScript will then be executed when the saved page is viewed or previewed.
Affected products
- Elementor Website Builder: before 3.1.4 — fixed in 3.1.4
How to fix
Upgrade to a fixed version: Elementor Website Builder 3.1.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/772e172f-c8b4-4a6a-9eb9-9663295cfedf
- https://www.wordfence.com/blog/2021/03/cross-site-scripting-vulnerabilities-in-elementor-impact-over-7-million-sites/
- https://wpscan.com/vulnerability/772e172f-c8b4-4a6a-9eb9-9663295cfedf
- https://www.wordfence.com/blog/2021/03/cross-site-scripting-vulnerabilities-in-elementor-impact-over-7-million-sites/
Get alerted when CVE-2021-24204 or the next vulnerability affects your stack