What’s Vulnerable › Vulnerabilities
CVE-2021-24207: WP Page Builder < 1.2.4 - Insecure default configuration Allows Subscribers Editing Access to Posts
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-05 · updated 2026-06-17
- Weakness: CWE-863
Description
By default, the WP Page Builder WordPress plugin before 1.2.4 allows subscriber-level users to edit and make changes to any and all posts pages - user roles must be specifically blocked from editing posts and pages.
Affected products
- WP Page Builder: before 1.2.4 — fixed in 1.2.4
How to fix
Upgrade to a fixed version: WP Page Builder 1.2.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/21e7a46f-e9a3-4b20-b44a-a5b6ce7b7ce6
- https://www.themeum.com/wp-page-builder-updated-v1-2-4/
- https://wpscan.com/vulnerability/21e7a46f-e9a3-4b20-b44a-a5b6ce7b7ce6
- https://www.themeum.com/wp-page-builder-updated-v1-2-4/
Get alerted when CVE-2021-24207 or the next vulnerability affects your stack