What’s Vulnerable › Vulnerabilities
CVE-2021-24208: WP Page Builder < 1.2.4 - Multiple Stored Cross-Site scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The editor of the WP Page Builder WordPress plugin before 1.2.4 allows lower-privileged users to insert unfiltered HTML, including JavaScript, into pages via the “Raw HTML” widget and the “Custom HTML” widgets (though the custom HTML widget requires sending a crafted request - it appears that this widget uses some form of client side validation but not server side validation), all of which are added via the “page_builder_data” parameter when performing the “wppb_page_save” AJAX action. It is also possible to insert malicious JavaScript via the “wppb_page_css” parameter (this can be done by closing out the style tag and opening a script tag) when performing the “wppb_page_save” AJAX action.
Affected products
- WP Page Builder: before 1.2.4 — fixed in 1.2.4
How to fix
Upgrade to a fixed version: WP Page Builder 1.2.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c20e243d-b0de-4ae5-9a0d-b9d02c9b8141
- https://www.themeum.com/wp-page-builder-updated-v1-2-4/
- https://wpscan.com/vulnerability/c20e243d-b0de-4ae5-9a0d-b9d02c9b8141
- https://www.themeum.com/wp-page-builder-updated-v1-2-4/
Get alerted when CVE-2021-24208 or the next vulnerability affects your stack