What’s Vulnerable › Vulnerabilities
CVE-2021-24209: WP Super Cache < 1.7.2 - Authenticated Remote Code Execution (RCE)
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 27.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-05 · updated 2026-06-17
- Weakness: CWE-94
Description
The WP Super Cache WordPress plugin before 1.7.2 was affected by an authenticated (admin+) RCE in the settings page due to input validation failure and weak $cache_path check in the WP Super Cache Settings -> Cache Location option. Direct access to the wp-cache-config.php file is not prohibited, so this vulnerability can be exploited for a web shell injection.
Affected products
- WP Super Cache: before 1.7.2 — fixed in 1.7.2
How to fix
Upgrade to a fixed version: WP Super Cache 1.7.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2496238/wp-super-cache
- https://wpscan.com/vulnerability/733d8a02-0d44-4b78-bbb2-37e447acd2f3
- https://plugins.trac.wordpress.org/changeset/2496238/wp-super-cache
- https://wpscan.com/vulnerability/733d8a02-0d44-4b78-bbb2-37e447acd2f3
Get alerted when CVE-2021-24209 or the next vulnerability affects your stack