What’s Vulnerable › Vulnerabilities
CVE-2021-24210: PhastPress < 1.111 - Open Redirect
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-05 · updated 2026-06-17
- Weakness: CWE-601
Description
There is an open redirect in the PhastPress WordPress plugin before 1.111 that allows an attacker to malform a request to a page with the plugin and then redirect the victim to a malicious page. There is also a support comment from another user one year ago (https://wordpress.org/support/topic/phast-php-used-for-remote-fetch/) that says that the php involved in the request only go to whitelisted pages but it's possible to redirect the victim to any domain.
Affected products
- kiboit PhastPress: before 1.111 — fixed in 1.111
How to fix
Upgrade to a fixed version: kiboit PhastPress 1.111. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2497610/
- https://wpscan.com/vulnerability/9b3c5412-8699-49e8-b60c-20d2085857fb
- https://plugins.trac.wordpress.org/changeset/2497610/
- https://wpscan.com/vulnerability/9b3c5412-8699-49e8-b60c-20d2085857fb
Get alerted when CVE-2021-24210 or the next vulnerability affects your stack