What’s Vulnerable › Vulnerabilities
CVE-2021-24213: GiveWP < 2.10.0 - Reflected Cross Site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The GiveWP – Donation Plugin and Fundraising Platform WordPress plugin before 2.10.0 was affected by a reflected Cross-Site Scripting vulnerability inside of the administration panel, via the 's' GET parameter on the Donors page.
Affected products
- stellarwp GiveWP – Donation Plugin and Fundraising Platform: from 2.4.0 before 2.10.0 — fixed in 2.10.0
How to fix
Upgrade to a fixed version: stellarwp GiveWP – Donation Plugin and Fundraising Platform 2.10.0. Check the vendor advisory for mitigations.
References
- https://bentl.ee/posts/cve-givewp/
- https://wpscan.com/vulnerability/da4ab508-a423-4c7f-a1d4-42ec6f989309
- https://bentl.ee/posts/cve-givewp/
- https://wpscan.com/vulnerability/da4ab508-a423-4c7f-a1d4-42ec6f989309
Get alerted when CVE-2021-24213 or the next vulnerability affects your stack