What’s Vulnerable › Vulnerabilities
CVE-2021-24216: All-in-One WP Migration < 7.41 - Admin+ Arbitrary File Upload to RCE
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-07 · updated 2026-06-17
- Weakness: CWE-434
Description
The All-in-One WP Migration WordPress plugin before 7.41 does not validate uploaded files' extension, which allows administrators to upload PHP files on their site, even on multisite installations.
Affected products
- servmask One-Stop Wp Migration: before 7.41 — fixed in 7.41
How to fix
Upgrade to a fixed version: servmask One-Stop Wp Migration 7.41. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2516181#file8
- https://wpscan.com/vulnerability/87c6052c-2628-4987-a9a3-a03b5ca1e083
- https://plugins.trac.wordpress.org/changeset/2516181#file8
- https://wpscan.com/vulnerability/87c6052c-2628-4987-a9a3-a03b5ca1e083
Get alerted when CVE-2021-24216 or the next vulnerability affects your stack