What’s Vulnerable › Vulnerabilities
CVE-2021-24217: Facebook for WordPress < 3.0.0 - PHP Object Injection with POP Chain
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-12 · updated 2026-06-17
- Weakness: CWE-502
Description
The run_action function of the Facebook for WordPress plugin before 3.0.0 deserializes user supplied data making it possible for PHP objects to be supplied creating an Object Injection vulnerability. There was also a useable magic method in the plugin that could be used to achieve remote code execution.
Affected products
- Facebook for WordPress: before 3.0.0 — fixed in 3.0.0
How to fix
Upgrade to a fixed version: Facebook for WordPress 3.0.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/509f2754-a1a1-4142-9126-ae023a88533a
- https://www.wordfence.com/blog/2021/03/two-vulnerabilities-patched-in-facebook-for-wordpress-plugin/
- https://wpscan.com/vulnerability/509f2754-a1a1-4142-9126-ae023a88533a
- https://www.wordfence.com/blog/2021/03/two-vulnerabilities-patched-in-facebook-for-wordpress-plugin/
Get alerted when CVE-2021-24217 or the next vulnerability affects your stack