What’s Vulnerable › Vulnerabilities
CVE-2021-24218: Facebook for WordPress 3.0.0-3.0.3 - CSRF to Stored XSS and Settings Deletion
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-12 · updated 2026-06-17
- Weakness: CWE-352
Description
The wp_ajax_save_fbe_settings and wp_ajax_delete_fbe_settings AJAX actions of the Facebook for WordPress plugin before 3.0.4 were vulnerable to CSRF due to a lack of nonce protection. The settings in the saveFbeSettings function had no sanitization allowing for script tags to be saved.
Affected products
- Facebook for WordPress: from 3.0.0 before 3.0.4 — fixed in 3.0.4
How to fix
Upgrade to a fixed version: Facebook for WordPress 3.0.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/169d21fc-d191-46ff-82e8-9ac887aed8a4
- https://www.wordfence.com/blog/2021/03/two-vulnerabilities-patched-in-facebook-for-wordpress-plugin/
- https://wpscan.com/vulnerability/169d21fc-d191-46ff-82e8-9ac887aed8a4
- https://www.wordfence.com/blog/2021/03/two-vulnerabilities-patched-in-facebook-for-wordpress-plugin/
Get alerted when CVE-2021-24218 or the next vulnerability affects your stack