What’s Vulnerable › Vulnerabilities
CVE-2021-24220: All Thrive Themes Legacy Themes < 2.0.0 - Unauthenticated Arbitrary File Upload and Option Deletion
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-12 · updated 2026-06-17
- Weakness: CWE-434
Description
Thrive “Legacy” Rise by Thrive Themes WordPress theme before 2.0.0, Luxe by Thrive Themes WordPress theme before 2.0.0, Minus by Thrive Themes WordPress theme before 2.0.0, Ignition by Thrive Themes WordPress theme before 2.0.0, FocusBlog by Thrive Themes WordPress theme before 2.0.0, Squared by Thrive Themes WordPress theme before 2.0.0, Voice WordPress theme before 2.0.0, Performag by Thrive Themes WordPress theme before 2.0.0, Pressive by Thrive Themes WordPress theme before 2.0.0, Storied by Thrive Themes WordPress theme before 2.0.0 register a REST API endpoint to compress images using the Kraken image optimization engine. By supplying a crafted request in combination with data inserted using the Option Update vulnerability, it was possible to use this endpoint to retrieve malicious code from a remote URL and overwrite an existing file on the site with it or create a new file.This includes executable PHP files that contain malicious code.
Affected products
- Thrivethemes Focusblog: before 2.0.0 — fixed in 2.0.0
- Thrivethemes Ignition: before 2.0.0 — fixed in 2.0.0
- Thrivethemes Luxe: before 2.0.0 — fixed in 2.0.0
- Thrivethemes Minus: before 2.0.0 — fixed in 2.0.0
- Thrivethemes Performag: before 2.0.0 — fixed in 2.0.0
- Thrivethemes Pressive: before 2.0.0 — fixed in 2.0.0
- Thrivethemes Rise: before 2.0.0 — fixed in 2.0.0
- Thrivethemes Squared: before 2.0.0 — fixed in 2.0.0
- Thrivethemes Storied: before 2.0.0 — fixed in 2.0.0
- Thrive Themes Voice: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: Thrivethemes Focusblog 2.0.0; Thrivethemes Ignition 2.0.0; Thrivethemes Luxe 2.0.0; Thrivethemes Minus 2.0.0; Thrivethemes Performag 2.0.0; Thrivethemes Pressive 2.0.0; Thrivethemes Rise 2.0.0; Thrivethemes Squared 2.0.0; Thrivethemes Storied 2.0.0; Thrive Themes Voice 2.0.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a2424354-2639-4f53-a24f-afc11f6c4cac
- https://www.wordfence.com/blog/2021/03/recently-patched-vulnerability-in-thrive-themes-actively-exploited-in-the-wild
- https://wpscan.com/vulnerability/a2424354-2639-4f53-a24f-afc11f6c4cac
- https://www.wordfence.com/blog/2021/03/recently-patched-vulnerability-in-thrive-themes-actively-exploited-in-the-wild
Get alerted when CVE-2021-24220 or the next vulnerability affects your stack