What’s Vulnerable › Vulnerabilities
CVE-2021-24225: Advanced Booking Calendar < 1.6.7 - Authenticated Reflected Cross-Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The Advanced Booking Calendar WordPress plugin before 1.6.7 did not sanitise the calId GET parameter in the "Seasons & Calendars" page before outputing it in an A tag, leading to a reflected XSS issue
Affected products
- Advanced Booking Calendar: before 1.6.7 — fixed in 1.6.7
How to fix
Upgrade to a fixed version: Advanced Booking Calendar 1.6.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2503971/
- https://wpscan.com/vulnerability/25ca8af5-ab48-4e6d-b2ef-fc291742f1d5
- https://plugins.trac.wordpress.org/changeset/2503971/
- https://wpscan.com/vulnerability/25ca8af5-ab48-4e6d-b2ef-fc291742f1d5
Get alerted when CVE-2021-24225 or the next vulnerability affects your stack