What’s Vulnerable › Vulnerabilities
CVE-2021-24226: AccessAlly < 3.5.7 - $_SERVER Superglobal Leakage
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-12 · updated 2026-06-17
- Weakness: CWE-200
Description
In the AccessAlly WordPress plugin before 3.5.7, the file "resource/frontend/product/product-shortcode.php" responsible for the [accessally_order_form] shortcode is dumping serialize($_SERVER), which contains all environment variables. The leakage occurs on all public facing pages containing the [accessally_order_form] shortcode, no login or administrator role is required.
Affected products
- AccessAlly: before 3.5.7 — fixed in 3.5.7
How to fix
Upgrade to a fixed version: AccessAlly 3.5.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/8e3e89fd-e380-4108-be23-00e87fbaad16
- https://wpscan.com/vulnerability/8e3e89fd-e380-4108-be23-00e87fbaad16
Get alerted when CVE-2021-24226 or the next vulnerability affects your stack