What’s Vulnerable › Vulnerabilities
CVE-2021-24228: Patreon WordPress < 1.7.2 - Reflected XSS on Login Form
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The Jetpack Scan team identified a Reflected Cross-Site Scripting in the Login Form of the Patreon WordPress plugin before 1.7.2. The WordPress login form (wp-login.php) is hooked by the plugin and offers to allow users to authenticate on the site using their Patreon account. Unfortunately, some of the error logging logic behind the scene allowed user-controlled input to be reflected on the login page, unsanitized.
Affected products
- Patreon WordPress: before 1.7.2 — fixed in 1.7.2
How to fix
Upgrade to a fixed version: Patreon WordPress 1.7.2. Check the vendor advisory for mitigations.
References
- https://jetpack.com/2021/03/26/vulnerabilities-found-in-patreon-wordpress-plugin/
- https://wpscan.com/vulnerability/7a5fadb1-3f1c-4779-8ff6-356fccb5269b
- https://jetpack.com/2021/03/26/vulnerabilities-found-in-patreon-wordpress-plugin/
- https://wpscan.com/vulnerability/7a5fadb1-3f1c-4779-8ff6-356fccb5269b
Get alerted when CVE-2021-24228 or the next vulnerability affects your stack